Problem
When Microbizz sends a mail to a user using Office365 as their mail program, the mail is never delivered. Instead the mail is returned with the following error message:
550 5.7.511 Access denied, banned sender[139.162.166.41]. To request removal from this list please forward this message to delist@messaging.microsoft.com. For more information please go to http://go.microsoft.com/fwlink/?LinkId=526653
Cause
Office365 has begun blocking most or all servers at our hosting partner regarding mails. Our current investigations points to an error at Microsoft, but also indicates that this is an error that have lasted for weeks and is escalating.
Workaround
For important mails, the only thing we can advise is to copy the mail text from Microbizz and send it using your own mail program. We know this is not a permanent or reasonable solution.
Next action
We are having a crisis meeting in problem management to discus which course of actions to take from here. We'll get back here afterwards expected Wednesday afternoon.
Updates
Wednesday, January 5th 11:10 | We have investigated the issue further, and can narrow the issue down to Office365 users. Users of other Microsoft mail solutions (outlook.com, live.com etc) are receiving mails from Microbizz |
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Wednesday, January 5th 10:03 | We have been in contact with our hosting partner, which informs us that this issue is widespread across their customer base, and that they are working closely with Microsoft to solve the issue. Thousands of solutions across the internet is affected by this. |
Wednesday, January 5th 09:40 | We have contacted Microsoft using official channels. Their automated systems report that our IP address isn't banned. |
Tuesday, January 4th 16:00 | We received the first reports of these errors. |